1
1
Fork 0
nixos/options/custom/services/zerotierone.nix
Myned 1dbd2b876c
zerotierone: initial service
Signed-off-by: Myned <dev@bjork.tech>
2024-09-28 13:06:11 -05:00

19 lines
375 B
Nix

{
config,
lib,
...
}:
with lib; let
cfg = config.custom.services.zerotierone;
in {
options.custom.services.zerotierone.enable = mkOption {default = false;};
config = mkIf cfg.enable {
#!! Configuration is imperative
# https://www.zerotier.com/
# https://github.com/zerotier/ZeroTierOne
services.zerotierone = {
enable = true;
};
};
}