1
1
Fork 0
nixos/options/custom/services/logind.nix
Myned ab485dec35
nix: format with alejandra
Signed-off-by: Myned <dev@bjork.tech>
2024-09-12 20:50:53 -05:00

16 lines
289 B
Nix

{
config,
lib,
...
}:
with lib; let
cfg = config.custom.services.logind;
in {
options.custom.services.logind.enable = mkOption {default = false;};
config = mkIf cfg.enable {
services.logind = {
lidSwitch = "suspend-then-hibernate"; # Laptop lid switch
};
};
}