1
1
Fork 0
nixos/options/custom/services/gpg-agent.nix
Myned ab485dec35
nix: format with alejandra
Signed-off-by: Myned <dev@bjork.tech>
2024-09-12 20:50:53 -05:00

19 lines
427 B
Nix

{
config,
lib,
pkgs,
...
}:
with lib; let
cfg = config.custom.services.gpg-agent;
in {
options.custom.services.gpg-agent.enable = mkOption {default = false;};
config.home-manager.users.${config.custom.username} = mkIf cfg.enable {
# https://wiki.archlinux.org/title/GnuPG#gpg-agent
services.gpg-agent = {
enable = true;
pinentryPackage = pkgs.pinentry-gnome3; # Default: curses
};
};
}