1
1
Fork 0
nixos/options/custom/services/fwupd.nix
Myned ab485dec35
nix: format with alejandra
Signed-off-by: Myned <dev@bjork.tech>
2024-09-12 20:50:53 -05:00

19 lines
359 B
Nix

{
config,
lib,
...
}:
with lib; let
cfg = config.custom.services.fwupd;
in {
options.custom.services.fwupd.enable = mkOption {default = false;};
config = mkIf cfg.enable {
# https://wiki.nixos.org/wiki/Fwupd
# https://github.com/fwupd/fwupd
services.fwupd = {
enable = true;
extraRemotes = ["lvfs-testing"];
};
};
}