1
1
Fork 0
nixos/options/custom/programs/wireshark.nix
Myned 31cc2f7441
nix: fix wireshark build
Signed-off-by: Myned <dev@bjork.tech>
2024-09-13 13:45:22 -05:00

21 lines
418 B
Nix

{
config,
lib,
pkgs,
...
}:
with lib; let
cfg = config.custom.programs.wireshark;
in {
options.custom.programs.wireshark.enable = mkOption {default = false;};
config = mkIf cfg.enable {
# https://gitlab.com/wireshark/wireshark
programs.wireshark = {
enable = true;
package = pkgs.wireshark; # GUI
};
users.users.${config.custom.username}.extraGroups = ["wireshark"];
};
}