1
1
Fork 0
nixos/options/custom/programs/tmux.nix
Myned ab485dec35
nix: format with alejandra
Signed-off-by: Myned <dev@bjork.tech>
2024-09-12 20:50:53 -05:00

20 lines
370 B
Nix

{
config,
lib,
...
}:
with lib; let
cfg = config.custom.programs.tmux;
in {
options.custom.programs.tmux.enable = mkOption {default = false;};
config = mkIf cfg.enable {
# https://wiki.nixos.org/wiki/Tmux
# https://github.com/tmux/tmux
programs.tmux = {
enable = true;
shortcut = "t";
terminal = "tmux-256color";
};
};
}