1
1
Fork 0
nixos/options/custom/programs/tio.nix
Myned ab485dec35
nix: format with alejandra
Signed-off-by: Myned <dev@bjork.tech>
2024-09-12 20:50:53 -05:00

22 lines
566 B
Nix

{
config,
lib,
...
}:
with lib; let
cfg = config.custom.programs.tio;
in {
options.custom.programs.tio.enable = mkOption {default = false;};
config = mkIf cfg.enable {
# Allow serial device access
# https://github.com/tio/tio?tab=readme-ov-file#46-known-issues
users.users.${config.custom.username}.extraGroups = ["dialout"];
# https://github.com/tio/tio
#!! Options not available, files written directly
home-manager.users.${config.custom.username}.home.file.".config/tio/config".text = ''
baudrate = 9600
'';
};
}