1
1
Fork 0
nixos/options/custom/programs/direnv.nix
Myned ab485dec35
nix: format with alejandra
Signed-off-by: Myned <dev@bjork.tech>
2024-09-12 20:50:53 -05:00

19 lines
350 B
Nix

{
config,
lib,
...
}:
with lib; let
cfg = config.custom.programs.direnv;
in {
options.custom.programs.direnv.enable = mkOption {default = false;};
config = mkIf cfg.enable {
# https://github.com/direnv/direnv
programs.direnv = {
enable = true;
loadInNixShell = false; # nix develop
silent = true;
};
};
}