1
1
Fork 0
nixos/options/custom/files/mnt.nix
Myned ab485dec35
nix: format with alejandra
Signed-off-by: Myned <dev@bjork.tech>
2024-09-12 20:50:53 -05:00

15 lines
265 B
Nix

{
config,
lib,
...
}:
with lib; let
cfg = config.custom.files.mnt;
in {
options.custom.files.mnt.enable = mkOption {default = false;};
config = mkIf cfg.enable {
# Set /mnt permissions
systemd.tmpfiles.rules = ["z /mnt 0755 root root"];
};
}