1
1
Fork 0
nixos/options/custom/files/dev.nix
Myned ab485dec35
nix: format with alejandra
Signed-off-by: Myned <dev@bjork.tech>
2024-09-12 20:50:53 -05:00

16 lines
406 B
Nix

{
config,
lib,
...
}:
with lib; let
cfg = config.custom.files.dev;
in {
options.custom.files.dev.enable = mkOption {default = false;};
config.home-manager.users.${config.custom.username} = mkIf cfg.enable {
# .keep empty file needed to create empty directory
# https://github.com/nix-community/home-manager/issues/2104
home.file.".dev/.keep".text = ""; # Development folder
};
}