37 lines
1.3 KiB
Nix
37 lines
1.3 KiB
Nix
# Do not modify this file! It was generated by ‘nixos-generate-config’
|
||
# and may be overwritten by future invocations. Please make changes
|
||
# to /etc/nixos/configuration.nix instead.
|
||
{
|
||
config,
|
||
lib,
|
||
pkgs,
|
||
modulesPath,
|
||
...
|
||
}: {
|
||
imports = [(modulesPath + "/installer/scan/not-detected.nix")];
|
||
|
||
boot.initrd.availableKernelModules = [
|
||
"nvme"
|
||
"dwc3_pci"
|
||
"xhci_pci"
|
||
"usbhid"
|
||
"usb_storage"
|
||
"sd_mod"
|
||
"sdhci_pci"
|
||
];
|
||
boot.initrd.kernelModules = [];
|
||
boot.kernelModules = ["kvm-amd"];
|
||
boot.extraModulePackages = [];
|
||
|
||
# Enables DHCP on each ethernet and wireless interface. In case of scripted networking
|
||
# (the default) this is the recommended approach. When using systemd-networkd it's
|
||
# still possible to use this option, but it's recommended to use it in conjunction
|
||
# with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
|
||
networking.useDHCP = lib.mkDefault true;
|
||
# networking.interfaces.enp4s0f3u1u1.useDHCP = lib.mkDefault true;
|
||
# networking.interfaces.enp4s0f3u1u2.useDHCP = lib.mkDefault true;
|
||
# networking.interfaces.wlo1.useDHCP = lib.mkDefault true;
|
||
|
||
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
|
||
hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
|
||
}
|