1
1
Fork 0
nixos/options/custom/programs/ssh.nix
Myned 2c4d84ec9b
ssh: enable host key checking
Signed-off-by: Myned <dev@bjork.tech>
2025-01-29 14:10:39 -06:00

23 lines
580 B
Nix

{
config,
lib,
...
}:
with lib; let
cfg = config.custom.programs.ssh;
in {
options.custom.programs.ssh.enable = mkOption {default = false;};
config = mkIf cfg.enable {
home-manager.users.${config.custom.username} = {
programs.ssh.enable = true;
# Work around FHS permissions
# https://github.com/nix-community/home-manager/issues/322#issuecomment-1856128020
home.file.".ssh/config" = {
target = ".ssh/config_source";
onChange = "cat ~/.ssh/config_source > ~/.ssh/config && chmod 400 ~/.ssh/config";
};
};
};
}