1
1
Fork 0
nixos/options/custom/programs/firefox/firefox.nix
Myned bb606b807c
nix: ignore .*.nix modules
Signed-off-by: Myned <dev@bjork.tech>
2025-02-18 09:05:05 -06:00

35 lines
621 B
Nix

{
config,
inputs,
lib,
pkgs,
...
}:
with lib; let
cfg = config.custom.programs.firefox;
in {
options.custom.programs.firefox = {
enable = mkOption {default = false;};
};
config = mkIf cfg.enable {
home-manager.sharedModules = [
{
# https://www.mozilla.org/en-US/firefox/developer
programs.firefox = mkMerge [
(import ./.common.nix {inherit config inputs lib pkgs;})
{
enable = true;
}
];
home.file = {
".mozilla/profiles.ini" = {
force = true;
};
};
}
];
};
}