1
1
Fork 0
nixos/options/custom/desktops/hyprland/monitors.nix
Myned ff341930c9
desktops: refactor and switch to hyprland
Signed-off-by: Myned <dev@bjork.tech>
2025-02-13 22:04:16 -06:00

30 lines
863 B
Nix

{
config,
lib,
...
}:
with lib; let
cfg = config.custom.desktops.hyprland.monitors;
in {
options.custom.desktops.hyprland.monitors = {
enable = mkOption {default = false;};
};
config = mkIf cfg.enable {
home-manager.sharedModules = [
{
wayland.windowManager.hyprland.settings = {
# https://wiki.hyprland.org/Configuring/Monitors
#?? monitor = NAME, RESOLUTION, POSITION, SCALE
monitor = mkBefore [
", highrr, auto, ${toString config.custom.scale}"
# HACK: Ensure the fallback output has a sane resolution
# https://github.com/hyprwm/Hyprland/issues/7276#issuecomment-2323346668
#// "FALLBACK, ${toString config.custom.width}x${toString config.custom.height}@60, auto, ${toString config.custom.scale}"
];
};
}
];
};
}